Das offizielle Minecraft Wiki twittert hier: Wiki-Twitter  –  Chatte im Wiki-Discord  – Noch keinen Server gefunden? Es gibt einen Wiki-Server

Diskussion:Güter-Beladegleis (Redstone)

Aus Technik Wiki
Wechseln zu: Navigation, Suche

Nachbau[Quelltext bearbeiten]

Hi also ich hab versucht eben die Variante 2 nachzubauen, leider funktionierts so nicht bei mir..... der Kolben bewegt sich zwar jedes mal wenn das Signal ein Block weiter switcht aber danach passiert nichts.... aber wenn die Lore befüllt ist (bzw wenn alle Slots belegt sind, aber nicht mit 64 Einheiten) passiert gar nichts mehr :/ die beiden Trichter sind die Taktgeber oder? in einen von beiden hab ich 64 Einheiten von "irgendwas" getan, diese fließen immer komplett in den rechten (also auf dem in deiner Steuerung der Redstoneblock ist)

ich kann mir keinen reim drauf machen.... leider verstehe ich noch nicht alle Funktionen der Steuerung um mir selbst zu helfen :(

Hoffe du kannst es!

Vorderansicht.png
Rückansicht.png


-beatlejuice89-Beatlejuice89 (Diskussion) 15:09, 24. Sep. 2014 (UTC)

Hallo Beatlejuice89, ich wüsste zur Zeit nicht woran es liegt. Könntest du noch eine Draufsicht machen ? Also der Taktgeber gibt immer nach dem die 64 Gegenstände verschoben sind ein Signal an die Speicherzelle, nun ist es so, wenn diese durch den Taktgeber aktiviert ist, gibt diese ein Signal an ein Und-Gatter und wenn nun ein weiterer Takt vom Taktgeber kommt, so wird das Und-Gatter geschaltet und der Kolben der die Lore losfahren lässt wird für einen kurzen Moment zurück gezogen. Probier vielleicht mal aus, ob die Lore überhaupt losfahren kann, wenn das Und-Gatter durchschaltet. Falls das nicht klappt musst du vielleicht mal nach dem Impulsgeber schauen, es könnte sein, dass dieser zu schnell eingestellt ist. Nethonos (Diskussion) 15:39, 24. Sep. 2014 (UTC)
DRAUFSICHT.png
Also der Zähler sind die trichter mit den Kolben oder? sind beide Kolben klebrig oder nur der eine?
sind in den trichtern 1x64 oder 5x64 dinge?
(die Komperatoren sprechen doch erst an wenn der Trichter voll ist oder?)
wenn der Impulsgeber sich bewegt liegt an dem Verzögerer (Stufe 4) ein Signal an... danach geht ist es aber nirgends weiterzuverfolgen.....
Impuls.png
gibts etwas was man nicht sieht auf deinen Screenshots?
hast du vielleicht ne Welt in der man das anschauen kann zum Download? --Beatlejuice89 (Diskussion) 15:58, 24. Sep. 2014 (UTC)
Ich hab mir das mal angeschaut, du hast meinen Erachtens alles richtig gebaut. Eine Kleinigkeit, welche aber das Problem an sich vermutlich nicht behebt, wäre dass du am besten die Verstärker vom Taktgeber nicht zu den Komparatoren setzt, sondern zu dem Redstone-Kabel welches durch die genannten Komparatoren angesteuert wird (Habs auch auf den Bildern von der Variante 2 aktualisiert).
Für eine Download-Welt muss du dich noch gedulden, denn wie bei den Redstone-Schaltkreisen ist auch eine Download-Welt für die Schienenverkehrsanlagen geplant, indes dauert das aber noch schätzungsweise 2 Monate bis die Welt verfügbar sein wird (Sie ist gekoppelt mit der Fertigstellung der Schienenverkehrsanlagen).
Um bei dieser Frage zu antworten, musst du auf "Bearbeiten" direkt neben "Nachbau" klicken, dann musst du nicht jedesmal eine neue Frage erstellen. Nethonos (Diskussion) 16:45, 24. Sep. 2014 (UTC)
Also ich hab die Steuerung jetzt so Aktualisiert wie auf deinen Bildern.... zumindest rattert der Zähler jetzt hin und her wenn ein wagen auf der Signalschiene steht. fraglich ist für mich immernoch wo das signal von dem impulsgeber hingeht (Bild mit pfeil)
außerdem hat die leitung, die von dem impulsgeber zum undgatter geht bei dir "spannung" wenn kein wagen drauf steht. wo kommt die her? von dem taktgeber?
ich verzweifle hier dran ^^
--peace! (Diskussion) 17:04, 24. Sep. 2014 (UTC)--peace! (Diskussion) 17:04, 24. Sep. 2014 (UTC)
Ich hab die ansichten mal aktualisiert - so kannst du ja mal schauen was schief gegangen ist bei mir o.o
--peace! (Diskussion) 17:15, 24. Sep. 2014 (UTC)
Ok, also das Signal vom Impulsgeber (Bild mit Pfeil) geht in die Speicherzelle, dadurch bleibt die inaktiv. Nun das Und-Gatter ist deswegen bei mir geschaltet, weil das Signal der Speicherzelle dort anliegt. Denn die Speicherzelle + Und-Gatter funktionieren hier als primitiver Zähler. Das bedeutet, wenn der Impulsgeber (Pfeil) ein Signal auf die Speicherzelle gibt, so wird diese immer zurückgesetzt, damit das Signal beim Und-Gatter erlischt. Der Taktgeber wiederum aktiviert dauernd die Speicherzelle. Wenn nun die Speicherzelle aktiviert wurde und der Taktgeber ein weiteres mal die Speicherzelle setzen will, diese aber schon gesetzt ist, so wird das Und-Gatter durchgeschaltet und aktiviert den Impulsgeber der am Ausgang des Und-Gatters liegt. Kann es sein dass du nicht lange genug wartest bis die Lore los geschickt wird ? Weil nur wenn der Zähler bis 2 gezählt hat (Taktgeber hat zweimal die 64 Gegenstände komplett verschoben), wird das Und-Gatter geschaltet und die Lore müsste dann los fahren. Nethonos (Diskussion) 17:54, 24. Sep. 2014 (UTC)
also irgendwie speichert die Speicherzelle bei mir, glaube ich, nichts. hab mal das Impulsgeberbild noch aktualisiert.
also ich warte sicherlich lang genug...
Prinzipiell ist das doch so gedacht, dass der Impulsgeber mit seinem Signal die Speicherzelle immer negiert und sobald er nichts mehr macht die Spannung dann anliegt oder? und die Spannung setzt die eine Seite vom und Signal... und wenn der Zähler dann sein Signal dazu gibt lässt der Kolben unten den wagen fahren....
mein Problem ist nur dass die Speicherzelle nicht unter Spannung steht - und so also nie das Und-Glied aktivieren kann....
also egal was ich tue, irgendwie hat dieser Impulsgeber keinen Einfluss auf die Speicherzelle....
könntest du vielleicht nochmal nen genaueres bild des Impulsgebers und der Speicherzelle machen? vielleicht hab ich nur was vergessen oO --peace! (Diskussion) 18:25, 24. Sep. 2014 (UTC)
Also auf deinen aktualisierten Bild mit dem Pfeil, wird der Verstärker nur dann aktiviert, wenn die Redstone-Fackel, welche das Redstone-Kabel direkt vor dem Verstärker kurz aktiviert. Wenn also der Taktgeber seine klebrigen Kolben (beide klebrig) nun verschiebt, sodass kurz das Signal vom Komparator erlischt, so wird kurz die Redstone-Fackel aktiv und wieder aus gehen. Nun, dieses kurze Signal setzt die Speicherzelle. Und wenn das zweimal geschieht, ohne das der Impulsgeber der die Speicherzelle zurücksetzt, so wird für einen Moment das Und-Gatter von beiden Eingängen aktiviert und dieses schaltet durch. Noch eine Frage, gibt die Sensorschiene ein Signal durch den komparator ab und dieser weiter an den Goldblock, welcher dann vom Verstärker abgegriffen wird ? Weil wenn dieser Verstärker nicht aktiv ist, dann funktioniert das ganze nicht.
Ahhhh, ich glaube ich weiss was los ist, schau dir mal bitte die NOR-Latch Speicherzelle an. Denn eine Speicherzelle ist ein geschlossener Kreis! Bei dir fehlt eine Redstone-Fackel !!! Nethonos (Diskussion) 18:30, 24. Sep. 2014 (UTC)
wo denn??? o.o mach mal nen bild bei dir wo diese fehlt.... mir fällt das grad schwer das rüberzuprojezieren von dem Nor-Latch (das Nor-Glied ist praktisch unsere Speicherzelle oder?) --peace! (Diskussion) 18:37, 24. Sep. 2014 (UTC)
Hier, diese Redstone-Fackel, fehlt vermutlich bei dir: Nethonos (Diskussion) 18:41, 24. Sep. 2014 (UTC)
JAAAAAAAAAAAA!!! Das war es :D Vielen vielen dank!!! ich hätte sonst nicht ruhig penn können heut Nacht :D
nur ein problem hab ich noch, der Kolben der den wagen losfahren lassen soll fährt so kurz aus dass er den wagen vom gleis schiebt anstatt weiterfahren zu lassen.... ._.* --peace! (Diskussion) 18:50, 24. Sep. 2014 (UTC)
Setzt einfach den Kolben wie in Variante 3 (von oben ausgerichtet) und einen Verstärker auf Stufe 2 oder 3, dann müsste es funktionieren.
Es freut mich, dass es doch Leute gibt die sich mit Schienenverkehrsanlagen auseinander setzen ;). Schließlich ist das ein etwas schwierigeres Thema als die Redstone-Schaltkreise. Nethonos (Diskussion) 18:54, 24. Sep. 2014 (UTC)
Ja so klappt das! Hab nochmal vielen Dank! ja war ganz schön heavy das zu verstehen! aber dank dir hab ich das prinzip verstanden.... :D
Thumbs up! --peace! (Diskussion) 19:08, 24. Sep. 2014 (UTC)
Wäre ja auch schön blöd, wenn man daran selbst hockt und es nicht erklären könnte ^^. Nethonos (Diskussion) 19:16, 24. Sep. 2014 (UTC)